Cisco VTP on HP Switches?

 

Want to propergate vLan information across multiple switches?

Easy in the Cisco world…  Just use VTP – configure a server switch and  your away… (it also has its risks if you introduce another server switch with a lower ID)

What does HP have?  — GVRP (MVRP newer iteration).

http://en.wikipedia.org/wiki/Multiple_Registration_Protocol

Multiple VLAN Registration Protocol (MVRP), which replaced GARP VLAN Registration Protocol (GVRP), is a standards-based Layer 2 network protocol, for automatic configuration of VLAN information on switches. It was defined in the 802.1ak amendment to 802.1Q-2005.

MSTP – nice blog on its inner workings here – http://blog.ine.com/2010/02/22/understanding-mstp/

 


ESX – network utilization

One of the best articles i have found on this subject is here : http://blog.scottlowe.org/2008/07/16/understanding-nic-utilization-in-vmware-esx/

There is some additional information here on setting up an etherchannel on the cisco side : http://blog.scottlowe.org/2006/12/04/esx-server-nic-teaming-and-vlan-trunking/

This can be handy if you need a single VM to use both physical nics in a load-balanced manner – both outbound and inbound. Of course its not really that simple though. This will really only add a benefit if the VM is communicating to multiple destinations (using ip hash – a single destination from a single VM with one IP will always be limited to the same physical nic).

switch(config)#int port-channel 1
switch(config-if)#description NIC team for ESX server
switch(config-if)#int gi0/1
switch(config-if)#channel-group 1 mode on
switch(config-if)#int gi0/2
switch(config-if)#channel-group 1 mode on

As per the article ensure you are using the same etherchannel method. The first command shows your current load-blance method, the 2nd command changes it to ip hash.

show etherchannel load-balance
port-channel load-balance src-dst-ip

Another solution is to use multiple iSCSI paths. This is newly supported within vSphere, see this post on setting up multiple paths : http://goingvirtual.wordpress.com/2009/07/17/vsphere-4-0-with-software-iscsi-and-2-paths/

Here is another good article on iSCSI within vSphere : http://www.delltechcenter.com/page/A+“Multivendor+Post”+on+using+iSCSI+with+VMware+vSphere

Some important points on using EMC Clariion with vSphere : http://virtualgeek.typepad.com/virtual_geek/2009/08/important-note-for-all-emc-clariion-customers-using-iscsi-and-vsphere.html

Cisco – adding a static route to router

To show what routes your cisco router currently has loaded type the following command (from the enable prompt) ;

show ip route

To add any new static routes you need to use the following command (from the config terminal prompt) ;

ip route 10.10.20.0 255.255.255.0 192.168.100.1

the syntax as above is ip route network netmask gateway


Router on a stick – Adding VLANs to a cisco router

Telnet to your cisco router, enable then go into config t. Passwords may be required depending on how it has been configured…

en

config t

Ensure that ip routing has been enabled…

ip routing

To create the VLAN adapter you’ll need to run the following commands to create a “router on a stick”…   Note: the .2 after the interface name creates a virtual adapter on the interface.

interface FastEthernet1/1.2
description “VM Host Network”
encapsulation dot1Q 2
ip address 172.25.2.1 255.255.255.0

The following is another example of a VLAN (110) on a router. This one has the ip helper-address (DHCP server) specified for this range.

interface FastEthernet1/1.110
description “Ak IDN”
encapsulation dot1Q 110
ip address 172.25.20.1 255.255.255.0
ip helper-address 172.25.20.15

That is the router side of things setup. Remember to save your changes via…

copy run start

Now you’ll need to add the VLAN to your switches. If you have VTP in your environment its as simple as adding the extra vlan onto your “server” vtp switch. Telnet (or null cable) to your “server” switch and go into “enable” mode, then go into the vlan database and add the required vlans as per above…

en

vlan database

vlan 2 name “VM Host Network”

vlan 110 name “Ak IDN”

VTP will propagate the vlans out to your client switches. Done.

Cisco – Switch Reference

Setting up a trunk between switches

Enable Switch to enable mode
Configure Terminal Enter global configuration mode

Interface FastEthernet0/1 Entering interface configuration for port 0/1. This is where you pick the port you want to trunk.

Switchport mode trunk Set port to trunking mode.

Switchport trunk encapsulation dot1q Set trunk type to 802.1q. If your switch only supports either ISL or 802.1q, this command does not exist because there is nothing to specify. This command only works when you can choose between the two.

Switchport trunk allow vlan 10-15,20 Allow only VLANs 10 through 15 and VLAN 20. It is important that you restrict the VLANs to only the ones you need for security best practices.

Exit Exit interface

Exit Exit global configuration

copy run start – save changes to nvram

Setting a switch up as a vtp client…. (VLAN client — cannot modify VLAN information)

vlan database enter vlan database

vtp client set switch vtp to client mode

vtp domain domain-name set switch to this domain – server switch will propergate vlan information across

possible to also set a password

Reset switch to factory defaults….

write erase

reload

Ensure you select NO to “do you wish to save changes”

How to make changes to multiple ports at same time;

interface range FastEthernet 0 – 23 (works on newer IOS)

Else its good ole notepad and terminal – rem that Ctrl-C (as it is sent to the session) does not work in terminial, you have to right cilck and copy. Though its easier to start a capture straight after you type show running-config, modify in notpad and paste back into config terminal.